Author Topic: hi need help :)  (Read 273 times)

0 Members and 1 Guest are viewing this topic.

ssphoenix

  • Cheater Apprentice
  • *
  • Posts: 19
    • View Profile
hi need help :)
« on: August 31, 2017, 08:03:59 pm »
guys how can i update crack version 1.16 to 1.72 ?


JazzIvan

  • Klass Klown
  • ***
  • Posts: 319
  • Killing Jokes
    • View Profile
Re: hi need help :)
« Reply #1 on: September 01, 2017, 01:50:56 am »
I had ghosted around Chinese M & B community outragously for a long time since 2015...I had done server bombs,  second-gen TW/Fiana dual access servers and translated/sold hacks to Chinese players... now I'm doing AOE 3 hacks as well as exploits.